Vue3将是个失败的项目

最新尝试把一个项目从vue2.x迁移到vue2
发现太多坑填不了

如果只是调整自己的代码就能解决,那还好
但有个最大的问题,就是不兼容第三方库基于2.x的库
最近几年,第三方的库蓬勃发展,因此也有大量库没有一直维护,所以很大一部分库不会升级到vue3
所以,依赖于这些库的项目也只能放弃升级到vue3

让我们继续使用vue2.x吧

迁移到Vue3确实是非常难办,新项目可以考虑Vue3,老项目要是能等到迁移工具说不定也行

2 → 3 的问题,Migration Build 可解(目前还没出)。「第三方的库蓬勃发展,因此也有大量库没有一直维护」,那为什么还要用这些库呢,找替代或者自己 fork 一个维护不就得了。

有没有迁移说明 vue2 composition api 到 vue3

如果您的有足够的代码洁癖根本不需要这么多第三方库。
当您使用第三方库时也不一定非得使用和Vue版本耦合的。
例如使用 Swiper 时,您可以使用官方版本的,而不是 vue-awesome-swiper

我相信Vue3已经完整到足够供生产环境使用了,当遇到坑时希望您首先考虑是不是漏学了什么内容或者漏看了什么注意事项,这方面都有足够的官方中文文档。