vue不能兼容QQ浏览器吗,可以改吗


#1

我查了下可以兼容1.2的,但我是最新版本的QQ浏览器就不行了为什么,还有就是ie11也不能兼容


#2

这样提问没人能帮得了你


#3

你是没有把es6转成es5吧,搜索下vue里面es6转es5就行了


#4

一般来说:使用了babel转码,并且添加了相应的垫片
只要浏览器支持Object.defineProperty 就能运行vue

当然低版本的存在部分兼容问腿,写的时候注意下。都有解决方案。


#5

不是不支持qq,是不支持ie 需要babel
通过npm install babel-polyfill
可以在入口文件(main.js) 引入
import ‘babel-polyfill’ //解决IE浏览器ES6的问题

另外楼主的提问水平需要提高,这样的提问,一般没办法了解你到底想问什么!问题抽述需要清楚明确,不要太过于抽像化