Vue-loader: named exports in *.vue files are ignored

Hi,
I have just taken over an application and I am trying to have it up and running locally before making any changes. After installing requested modules and building the app, in the browser’s console there is a message like this named exports in *.vue files are ignored. for each vue file.
This is package.json:

  "dependencies": {
    "babel-runtime": "^6.0.0",
    "braintree-web": "^2.27.0",
    "config": "^1.21.0",
    "getmdl-select": "^1.0.4",
    "material-design-lite": "^1.1.3",
    "material-ui-vue": "^0.1.4",
    "moment": "^2.14.1",
    "moment-timezone": "^0.5.5",
    "vue": "^1.0.21",
    "vue-analytics": "^5.1.1",
    "vue-datepicker": "^1.2.1",
    "vue-form": "^0.3.1",
    "vue-ga": "^1.0.0",
    "vue-recaptcha": "0.0.2",
    "vue-resource": "^0.9.1",
    "vue-router": "^0.7.13",
    "vue-validator": "^2.1.3",
    "vuex": "^1.0.0-rc"
  },
  "devDependencies": {
    "eslint": "^2.13.1",
    "eslint-config-standard": "^5.3.1",
    "eslint-friendly-formatter": "^2.0.5",
    "eslint-loader": "^1.3.0",
    "eslint-plugin-html": "^1.5.1",
    "eslint-plugin-promise": "^1.0.8",
    "eslint-plugin-standard": "^1.3.2",
    "babel-core": "^6.0.0",
    "babel-loader": "^6.0.0",
    "babel-plugin-transform-runtime": "^6.0.0",
    "babel-preset-es2015": "^6.0.0",
    "babel-preset-stage-2": "^6.0.0",
    "cross-env": "^1.0.6",
    "css-loader": "^0.23.0",
    "file-loader": "^0.8.4",
    "json-loader": "^0.5.4",
    "url-loader": "^0.5.7",
    "vue-hot-reload-api": "^1.2.0",
    "vue-html-loader": "^1.0.0",
    "vue-loader": "^8.2.1",
    "vue-style-loader": "^1.0.0",
    "webpack": "^1.12.2",
    "webpack-dev-server": "^1.12.0"
  }

I guess this error is related to vue loder, but I can’t figure out what to do to fix it.
I have already tried to update all the modules to the latest version, but it sounds more like a mission impossible because of the many major changes to do in the code.
Unfortunately, no other post addressing the same kind of issue is of help.
Any help would be pretty much appreciated.
Thank you

Basically the error means that you can only export the vue object as default.

In your .vue file:

<script>
// make sure you export by default here
export default {
  // Your vue component here
}
</script>

Solved! I needed to use vue-loader@8.3.1. Version 8.3.0 doesn’t work either.