Vue Axios PHP and Firefox

I am still learning.
I am using axios to send data to php file that will write the data to MYSQL.
Once that is done, it will send an email out.
This all works great in Chrome.
Not so much in Firefox.
In Firefox, the first time I fill out the form and hit the save button…nothing happens and I get some errors in the dev console. If I try it again, it will write the data to the database, update the web page but will not send the email. I get the same error in the dev console. I have crawled all over axios site, these forums, php sites, and several tutorial sites. Cannot seem to find out why this is happening.

axios({
                  method: 'post',
                  url: 'saveStatus.php',
                  data: this.statusData
                })
                  .then(function(response) {
                    console.log(response.data);
                })
                  .catch(function(error) {
                    console.log(error);
                });

and

axios({
            method: 'post',
            url: 'sendStatus.php',
            data: this.statusData
          })
            .then(function(response) {
              console.log(response.data);
          })
            .catch(function(error) {
              console.log(error);
          });

Here are the errors I get when I run this on FireFox

Error: Request aborted
    exports createError.js:16
    onabort xhr.js:107
    exports xhr.js:102
    exports xhr.js:15
    exports dispatchRequest.js:58
    request Axios.js:108
    exports bind.js:9
    sendStatusMessage appstatus.js:121
    statusSubmit appstatus.js:95
    VueJS 28
    <anonymous> appstatus.js:1
appstatus.js:130:23
Error: Request aborted
    exports createError.js:16
    onabort xhr.js:107
    exports xhr.js:102
    exports xhr.js:15
    exports dispatchRequest.js:58
    request Axios.js:108
    exports bind.js:9
    statusSubmit appstatus.js:81
    VueJS 28
    <anonymous> appstatus.js:1

Do you have any further information on this? What’s the HTTP status code of your request?

Are these the same errors as above? It sounds like this part is a browser issue, but this part

sounds like a server issue.

Hard to say though. There’s not much to go on. Please review our posting guidelines so your issue has the best chance of being resolved.

Thanks!