请问下各位大神,vue不兼容安卓5.0及其以下的低版本是什么原因也

import ‘babel-polyfill’
import Es6Promise from ‘es6-promise’
require(‘es6-promise’).polyfill()
Es6Promise.polyfill()
我也用了相关的方法还是不行

image

哥你是我的就行,可以找你私聊下不,这个地方我也设置了,也是没有效果image

能帮忙看下吗image

image image

image
这个放到最上面作为垫包

这个是放在main.js文件里面的最上面吗,目前我是放在最上面的,大哥能加你一个QQ远程操作下吗,小弟不胜感激

是的 es6-promise的引入和调用可以拿掉 入口entry引入main.js就行,不用再在此处注入babel-polyfill,这样试一下

那大哥这个 babel-polyfil不用在main.js引入吗

是否是这样呢 image

肯定还是要引入的啊!

image

大哥

这个不用在此处注入,是在哪个地方不需要注入也

main.js引用了babel-polyfill之后 webapck打包入口entry选项里面引入mian.js就行 不用再在entry选项里面在注入这个了 这个意思

哥,我才接触vue没有多久,可以帮忙远程操控下吗,这个问题困扰了很久,小弟不胜感激 qq:635141796

电脑上没装qq 兼容安卓4.4:第一点:把package.json里面的browserslist改一下【css兼容,你也已经改了】,
第二点:在main.js的第一行引入babel-polyfill就可以

把之前为兼容安卓4.4修改的地方全部注释或者删掉,只做这两点试一下

image

你好 我照着你说的做了 但是把打包好的代码放到Android4.4下运行就报了 Unexpected token … 的错误 我看了下打包后的js文件 是这里 off: function(…t) 出的错
1

2

3

查了一下github发布日志,vue没有说不支持安卓4.4。

我看了一下build打包之后的代码 然后用babeljs.cn转成js5 然后把里面的**替换的*之后就可以在6.0跑了 但是在4.4还是会报 Cannot read property ‘0’ of undefined

image
在这一行报错了