Uninstalling vue.js and starting again

macOS 10.13.6

Hello, I’ve not really done anything with vue.js yet, but in response to a tweet, I was persuaded to install vue.js v3.00 by running npm install -g @vue/cli. I think something has gone wrong, though, because when I tried to run vue serve against a minimal app.vue file, i get the following error:

 ERROR  Failed to compile with 1 errors                                                                                                                 21:22:55

This dependency was not found:

* ~entry in /usr/local/lib/node_modules/@vue/cli-service-global/template/main.js

To install it, you can run: npm install --save ~entry

When I try to run npm install --save ~entry as instructed, i get the error:

zsh: no such user or named directory: entry

So, I’ve concluded that I have probably done some horrendous damage to my vue.js setup, and I would be better served by uninstalling the entire vue.js installation and reinstalling v3.00 from scratch. I tried uninstalling using npm uninstall -g @vue/cl and got the message up to date in 0.097s. Doesn’t look as if the uninstall worked. A search on Google reveals that I am not the only one to get this message.

Googling also fails to find any useful information on uninstalling vue.js.

I realise that I am a complete noob where vue.js is concerned, so please be gentle with me, and tell me what I am doing wrong!

Thanks!

That npm message is misleading, it’s a standard npm response when it can’t resolve a dependency. All you need to do is also install the @vue/cli-service-global package as documented here:

https://cli.vuejs.org/guide/prototyping.html

You will also have to install the cli itself again, because the uninstall likely worked despite the uninspiring console message

Thanks for the reply, Linus! I reinstalled the cli and then installed the cli-service-global. Should I be concerned about the npm WARN deprecated bfj-node4@5.3.1: Switch to the 'bfj' package for fixes and new features! message which appeared when I did this?

I ran vue serve against a minimal app.vue containing:

<template>
  <h1>Hello!</h1>
</template>

I got the following error message:

 ERROR  Failed to compile with 1 errors                                                                                                                 00:04:41

This dependency was not found:

* ~entry in /usr/local/lib/node_modules/@vue/cli-service-global/template/main.js

To install it, you can run: npm install --save ~entry

Any ideas? Thanks!

I think I’ve sussed it. I ran vue serve app.vue rather than just vue serve, and I was able to behold my wondrous creation.

No, that’s from some nested dependency that we don’t really have to worry about.

Great!

I want to get started with vue on a Windows10 PC.
I see I already have these vue related folders in my node_modules folder:
@vue, vue and vue-cli.

In the command window, vue --version gives: ‘vue’ is not recognized as a command.
So I decided to do what the title of this topic says: uninstall and start again!

Typed this: npm uninstall vue-cli -g
It started running stuff, but now it is stuck:
2018-10-10_16-25-12

Can someone tell me how to proceed, to get vue working on my PC? (I have npm and node installed OK).

Note: Not sure whether i should have started a new topic or replied to the relevant topic already started by someone else. What is preferred?

Hi guys! sorry to bump into this conversation many months after. i’m new to vue and so far i’ve been able to create a new project or open a previous one, but right now i’m having issues with accessing a project i cloned from gitlab. it keeps giving me the error message in the screenshot attached. Any suggestions?

have you installed dependencies after cloning?

I’ve done that and it’s working now. Thanks