Problem with using Mongodb

Hello

I’m new for trying vue, npm, Mongodb.
I’m using Ubuntu 18.04.3 LTS

I get this in the Terminal of Visual Studio Code:

joris@joris-MS-7798:/d/website/vue$ npm install --save mongodb
npm WARN npm npm does not support Node.js v13.0.0-nightly20190802452b393c1f
npm WARN npm You should probably upgrade to a newer version of node as we
npm WARN npm can’t make any promises that npm will work with this version.
npm WARN npm Supported releases of Node.js are the latest release of 6, 8, 9, 10, 11, 12.
npm WARN npm You can find the latest version at https://nodejs.org/
npm WARN saveError ENOENT: no such file or directory, open ‘/d/website/vue/package.json’
npm WARN enoent ENOENT: no such file or directory, open ‘/d/website/vue/package.json’
npm WARN vue No description
npm WARN vue No repository field.
npm WARN vue No README data
npm WARN vue No license field.
npm WARN You are using a pre-release version of node and things may not work as expected

  • mongodb@3.4.1
    updated 1 package and audited 22 packages in 0.956s
    found 0 vulnerabilities

joris@joris-MS-7798:/d/website/vue$

How can I solve this?

npm WARN npm npm does not support Node.js v13.0.0-nightly20190802452b393c1f

As it says, you are using a nightly version of Node. These are just warnings and things should work, but there’s no guarantee. You should be using the LTS version of Node which is currently at 12.14.0

1 Like

When on the nodejs.org website, you must have clicked the “current” version, click on the LTS version :slight_smile:

Better yet, install NVM or ASDF (best done with Homebrew)

I use nvm, hbu? I’ve never heard of ASDF

So do I have to take 13.5.0 Current? This gives me the file linux-x64.tar.xz. How do I install this?

No the 12.14.0 LTS

Try using nvm.sh

This is the install script: curl -o- https://raw.githubusercontent.com/nvm-sh/nvm/v0.35.2/install.sh

You then go nvm install 12.14.0 && nvm use 12.14.0

1 Like

joris@joris-MS-7798:/d/software/webontwikkeling/vue$ ls
mongodb-compass_1.20.1_amd64.deb
install.sh node-v12.14.1-linux-x64.tar.xz
joris@joris-MS-7798:/d/software/webontwikkeling/vue$

It is not clear for me! I’m a beginner! How do I install node exactly? See here the files I downloaded!