Help for a Newbie - Vue.createApp is not a function

I’m on the first lesson of Vue Mastery Beginner path Vue 3 and I’m stuck out of the box.

The code is:

const app = Vue.createApp({
data() {
return {
product: ‘Socks’
}
}
})

Well, I found the problem. Apparently using the recommended CDN: doesn’t work! I tried the original url from the video and problem solved. What’s up?

What CDN url was you using? I just tried now and it works for me. Was you possibly looking at the Vue 2 CDN url?

For reference I tried: https://unpkg.com/vue@next

1 Like

Yes, I loaded the CDN for Vue 2 not 3. I must confess navigating around the Vue site between the two versions can get a bit confusing. Not always obvious. Anyway, thanks!

Hello, I would just like to share my experience with the same problem that you have encountered.

I just retyped the “Vue.” and chose the Vue.createApp from the autocomplete suggestions and it worked.

Hello @smanus
I have the same problem and it’s solved with the CDN link, just try out links
For vue 2 :

<script src="https://unpkg.com/vue"></script>

For vue 3 :

<script src="https://unpkg.com/vue@next"></script>