Failed to load resource: the server responded with a status of 404 (Not Found) app.c2115832.js:1

I use ‘vue ui’ and vue cli 3 .I create create project with vue ui. I run the build command without changing anything. When I run the index.html file from the generated dist folder, I get a few errors in the console

Failed to load resource: the server responded with a status of 404 (Not Found)
app.c2115832.js:1 

Failed to load resource: the server responded with a status of 404 (Not Found)
chunk-vendors.fb29d323.js:1 

Failed to load resource: the server responded with a status of 404 (Not Found)
app.c2115832.js:1 

Failed to load resource: the server responded with a status of 404 (Not Found)
app.8d0d60ac.css:1 

the files are in the folder

dist
| - index.html
| - favicon.ico
|  css
|  | - app.8d0d60ac.css
|  js
|  | - app.c2115832.js
|  | - app.c2115832.js.map
|  | - chunk-vendors.fb29d323.js
|  | - chunk-vendors.fb29d323.js.map
|  img
|  | - logo.82b9c7a5.png

do I have to make extra adjustments?

My solved problem:

baseUrl: ‘’ in that case.

sorry, I have the same error… what is the solution? I dont understand…

To run the files created by Vue in the browser, I first ran the NPM INSTALL -G serve command. I get the error that the page cannot be displayed when I open it later in the browser. For this I had to change the baseUrl setting. and this adjustment solved my problem

first install npm install -g serve

go to build folder and open command

serve

localhost:3000 (default port 3000);

fixed router.

1 Like

You need to install npm serve. (global installed)

npm install serve -g

then you need to write “serve” in the command window in the index.html file location. routers will work properly when you dobaseUrl: "" to work properly.

1 Like

(sorry for my English, I dont speak fluid english, but I try)

thanks a lot for your help, but actually i am trying to run this app on my server, (GoDaddy) with Plesk (windows), my app run perfectly on my computer (localhost and runnning serve), But once I put the dist content in the Virtual file on the domain, the page shows empty with an error “Failed to load resource: the server responded with a status of 404 (Not Found)” and I cant find information about this error.