Can no longer create any new vue projects with vue cli

Hi, I thought I would try out the new vue/cli version 3 but it stalls at ‘project name’ and will not continue. I have waited over 25 minutes and still no progress. I have removed version 3 of the cli but now I have a problem with version 2.9 I had been using.
I can still run existing projects created with version 2 but vue init now stalls at the same point (after entering project name) as vue/cli 3.
I have tried unistalling/installing vue-cli 2 but no luck.
I am on a windows 10 machine using node version 10.
No error messages are displayed so I have no idea what is causing the issues

Any advice would be appreciated, thanks.

It seems that a recent commit is using a part of the node API that contains a bug, and was only fixed in node >8.10

our next beta will contain a fallback for older node versions. You can fix it for yourself immediatly by updating node to at least 8.10


Thanks for your response but no that is not the issue. I already have node 10 installed as well as npm 6 but the situation remains.
CLI 3 just hangs after create command and CLI 2.9 won’t create any new projects either just hangs at project name after downloading the template. Running existing projects using CLI 2.9 is possible.

If both versions of the cli are not working for you, it’s probably a problem related to either your node/npm installation and/or OS, because vue-cli 3 is a total rewrite from and doesn’t share code with 2.9

Does the vue cli, either version, create a log of some sort that I can check as no errors are displayed?


No, there’s no log.

I would have to check but v3 should have a debug flag through an env variable.

Changing package.json
“inquirer”: “^3.3.0”,
“inquirer”: “^5.2.0”,

solves the problem for
vue-cli 2.9.5

Thanks but that is not the issue.
Firstly the vue-cli 2.9.5 does not even create any files/folders even the main project folder is not created by the cli. It just hangs on entering project name. Therefore no package.json file is created. Also I have never noticed inquirer as listed in any package.json file for any previous vue apps created with any version of the cli.
Like I said previously, I can still run existing vue projects with the cli but can not create new ones.

little misunderstanding here.
package.json is file of github project ( developers of vue-cli must change it).
If you want to repair your installation of vue-cli 2.9.5 :

cd %USERPROFILE%\AppData\Roaming\npm\node_modules\vue-cli
npm uninstall inquirer
npm install inquirer --save

vue-cli should be working after this.

Hi thanks for the reply, sorry I thought you were referring to local project package.json file.
I have done what you said and yes cli 2.9.5 seems to be working fine again, which is a relief :slight_smile:

After cli2.9 was working again I tried reinstalling cli 3 to see if the change made any difference. It did not and cli 3 still failed at creating project. This also had the side effect of breaking cli 2.9 again, so I assume that cli 3 edits this inquirer module in a way that breaks cli 2.9.5.
I have now removed cli 3 and made the changes to inquirer again and cli 2.9 is now working again. However I won’t be in a rush to try out cli 3 any time soon.

Thanks for your help.

You can use gitbash create your project